VPN Site to Site lenta

Para temas sobre las VPN, incluyendo la configuración, resolución de problemas e interoperabilidad.
Responder
alexv
Mensajes: 32
Registrado: 27 Mar 2014, 16:02

VPN Site to Site lenta

Mensaje por alexv » 19 Nov 2019, 17:01

Buenas tardes,

Tengo un problema y espero me puedan ayudar.

Tengo problemas de rendimiento al pasar trafico por la vpn,
He provado diferentes combimaciones, ya que tengo 3 lineas, 2 de 600mb simetricos y 1 de 1gb simetrico, tambien con diferentes equipos y 2 60d y 2 virtuales.

El resultadonsiempre es el mismo, no consigo tasas de transferencia superiores a 14mbs.

He probado algunas soluciones que he encontrado como cambiar la velocidad de los interfaces wan de auto a 1000full,ñero el rendimiento siempre es el mismo.

Mientras se hace la transferencia la cpu,ram y lineas no estan saturadas.

Podria ser del MTU?. Donde deberia cambiarlo.

Gracias por leer hasta aquí.

Avatar de Usuario
makco10
Mensajes: 1049
Registrado: 03 Jun 2011, 19:42
Ubicación: Honduras
Contactar:

Re: VPN Site to Site lenta

Mensaje por makco10 » 19 Nov 2019, 21:19

Hola,

¿Que FortiOS utilizas?

De que forma estas validando la velocidad de transferencia.

Saludos.
Defend Your Enterprise Network With Fortigate Next Generation Firewall

alexv
Mensajes: 32
Registrado: 27 Mar 2014, 16:02

Re: VPN Site to Site lenta

Mensaje por alexv » 20 Nov 2019, 09:30

Buenos días makco10, muchas gracias por atender mi petición.

El Forti virtual está en la versión 6.2.2 build 1010 el 60D en la versión 6.0.7 build0302

Las velocidades la estoy mirando con Iperf y también copiando una iso por CIFS, que realmente es para lo que me interesa conseguir más velocidad.

Al final para simplificar tengo los 2 Fortis conectados por vpn y un portátil conectado físicamente a cada uno, sin switches ni nada más.

Te agradezco la ayuda

Gracias.

Avatar de Usuario
makco10
Mensajes: 1049
Registrado: 03 Jun 2011, 19:42
Ubicación: Honduras
Contactar:

Re: VPN Site to Site lenta

Mensaje por makco10 » 20 Nov 2019, 15:54

Hola,

Excelente es la mejor forma de validar el rendimiento de transferencia, una consulta por casualidad estas utilizando software switch / hardware switch del lado LAN, si es asi intenta directo a una interface.

Te comparto un link que te podria ser util: https://blog.webernetz.net/fortigate-vpn-speedtests/

Saludos.
Defend Your Enterprise Network With Fortigate Next Generation Firewall

alexv
Mensajes: 32
Registrado: 27 Mar 2014, 16:02

Re: VPN Site to Site lenta

Mensaje por alexv » 20 Nov 2019, 22:42

Buenas makco10,

Gracias de nuevo por tu atención.

He probado configurando el Forti con las interface internal en modo switch y en modo interface pero los resultado son prácticamente los mismo, no se si te refieres a eso o es a poner un switch fisico entre el forti y el router del ISP.

Habia visto este enlace, de hecho probé lo de las 2 opciones en el Forti a raiz de este.

Otra cosa que no me cuadra y que no venga por ahí es que si hago un test de velocidad por ejemplo con la linea de 1gb simétrica, como mucho el test me da 300 subida 400 bajada.

Si hago el test con un portátil conectado al router de ISP me da casi el 1gb.

Podria venir por ah´?

Muchas gracias.

Avatar de Usuario
makco10
Mensajes: 1049
Registrado: 03 Jun 2011, 19:42
Ubicación: Honduras
Contactar:

Re: VPN Site to Site lenta

Mensaje por makco10 » 21 Nov 2019, 16:46

Hola,

Exactamente me referia a esto: He probado configurando el Forti con las interface internal en modo switch y en modo interface pero los resultado son prácticamente los mismo.

Y si intentas actualizar el firmware?, digo porque el hardware no es una limitante, ese modelo te soporte un rendimiento de 1Gbps para IPsec.

Lo otro seria que lo escales a fortinet y ver que otra recomendación logras obtener.

Saludos.
Defend Your Enterprise Network With Fortigate Next Generation Firewall

alexv
Mensajes: 32
Registrado: 27 Mar 2014, 16:02

Re: VPN Site to Site lenta

Mensaje por alexv » 25 Nov 2019, 12:57

Buenas,

Ya lo escale a forti sin resultados, aún estoy a la espera que me contesten.

Una cosa que veo raro es que si conecto un portátil al router del ISP directamente los test de velocidad me dan entre 890Mbs y 980Mbs. Ahora si conecto el portátil al forti y hago el test máximo me llega a 250-260Mbs

Igual podría ser este el problema?. Si ya el test no me da toda la velocidad de la linea tampoco me lo dará el tunel.

Sabes si esto es normal o hay que tocar algún parámetro de la interface WAN?.

Tengo desactivado todas las inspecciones de trafico (IPS, Antivirus, etc).

Avatar de Usuario
makco10
Mensajes: 1049
Registrado: 03 Jun 2011, 19:42
Ubicación: Honduras
Contactar:

Re: VPN Site to Site lenta

Mensaje por makco10 » 25 Nov 2019, 17:33

Hola,

Esto te pasa con un puerto especifico o has probado con otro puerto del Fortigate.

En cuanto a las configuraciones de velocidad normalmente se encuentra en auto, puedes intentar cambiar el speed del puerto:

https://kb.fortinet.com/kb/documentLink ... ID=FD30018

Saludos.
Defend Your Enterprise Network With Fortigate Next Generation Firewall

alexv
Mensajes: 32
Registrado: 27 Mar 2014, 16:02

Re: VPN Site to Site lenta

Mensaje por alexv » 27 Nov 2019, 10:35

Buenos dias Macko10,

Haré las pruebas que comentas.

Muchas gracias de nuevo por tu ayuda.

Responder